Wicd 1.5.0 su Slackware 12.1: connessioni WPA senza problemi

Lo ammetto: con il WEP e iwconfig non ho mai avuto problemi a configurare la mia scheda wireless. Anzi su Slackware avevo fino a qualche tempo fa uno script bash che impostava la wlan0 a dovere dopo aver caricato ndiswrapper come modulo. Ma ormai tenere ancora WEP come crittografia è rischioso e così mi sono dovuto convertire a WPA, anche su Slackware. Ho provato a configurare /etc/rc.d/rc.inet1.conf e rc.wireless.conf ma non ho avuto fortuna così ho deciso di piegarmi alla “dura legge della GUI” rivolgendomi all’unica che conosco che funzioni davvero bene per le connessioni WiFi: Wicd.

Per Slackware 12.1 esistono dei pacchetti della versione stabile 1.4.2 che si possono reperire su Slacky ma nel mio caso non hanno funzionato. Ecco perché ho seguito il link riportato sul sito ufficiale di Wicd e ho scaricato e installato il pacchetto realizzato da Robby Workman: wicd 1.5.0 rc10.

Basta installarlo da root con il solito:
installpkg wicd-1.5.0_rc10-noarch-1_rlw.tgz

Poi lanciare il demone:
/etc/rc.d/rc.wicd start

E finalmente da utente semplice avviare il client:
/usr/bin/wicd-client

Se tutto è andato bene nella tray area comparirà un’icona da cui potremo richiamare l’interfaccia grafica per la configurazione della nostra scheda wireless utilizzando sia WEP che WPA per crittografare le comunicazioni con il nostro router/access point.

2 commenti su “Wicd 1.5.0 su Slackware 12.1: connessioni WPA senza problemi

  1. Ciao, ho seguito il tuo consiglio e ho installato wicd.

    Però al momento di avviarlo mi risponde:

    File "/usr/lib/wicd/wicd-client.py" , line 42, in import dbus

    ImportError: No module named dbus

    Che significa tutto ciò? Non sono pratico di linix.

    Grazie per eventuale risposta. Ho cercato in giro nei vari post ma non ho capito una mazza.

  2. # Robby Workman Says:

    Agosto 12th, 2008 at 6:16 am

    What Slackware version are you running? It looks like you don’t have the “dbus-python” package installed. It’s included with Slackware 12.1, but if you’re on a previous release of Slackware, it’s not. If you’re on 12.0, you’ll also need to get pygtk and its dependencies; if you’re on 11.0, I honestly have no idea what all you’ll need, so I’ll just recommend upgrading to 12.1 🙂

    # detroox Says:

    Agosto 20th, 2008 at 2:57 pm

    Proprio quello che cercavo..semplice ed efficiente..grazie!

    # daniele50 Says:

    Agosto 25th, 2008 at 9:46 pm

    Il programma si installa e parte correttamente, ma dove metto la chiave WEP??

    # daniele50 Says:

    Agosto 25th, 2008 at 9:56 pm

    Scusate, ho trovato, ma quando clicco su Connect ci prova per un istante ma poi risulta sempre disconnesso

I commenti sono chiusi.